|
a/packaging/debian/debian/rules |
|
b/packaging/debian/debian/rules |
|
... |
|
... |
7 |
|
7 |
|
8 |
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
|
8 |
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
|
9 |
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
|
9 |
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
|
10 |
|
10 |
|
11 |
CFLAGS = -Wall -g
|
11 |
CFLAGS = -Wall -g
|
12 |
LDFLAGS = -Wl,-z,defs
|
12 |
#LDFLAGS = -Wl,-z,defs
|
13 |
|
13 |
|
14 |
#build qt4 UI only
|
14 |
#build qt4 UI only
|
15 |
export QMAKE=qmake-qt4
|
15 |
export QMAKE=qmake-qt4
|
16 |
|
16 |
|
17 |
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
|
17 |
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
|
|
... |
|
... |
31 |
build: build-arch build-indep
|
31 |
build: build-arch build-indep
|
32 |
build-arch: build-stamp
|
32 |
build-arch: build-stamp
|
33 |
build-indep: build-stamp
|
33 |
build-indep: build-stamp
|
34 |
build-stamp: config.status
|
34 |
build-stamp: config.status
|
35 |
dh_testdir
|
35 |
dh_testdir
|
36 |
$(MAKE) -j 5
|
36 |
$(MAKE)
|
37 |
touch $@
|
37 |
touch $@
|
38 |
|
38 |
|
39 |
clean:
|
39 |
clean:
|
40 |
dh_testdir
|
40 |
dh_testdir
|
41 |
dh_testroot
|
41 |
dh_testroot
|