Switch to unified view

a b/packaging/rpm/recoll-opensuse.spec
1
#
2
# spec file for package recoll
3
#
4
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name:           recoll
20
Version:        1.21.6
21
Release:        0
22
Summary:        Extended Search
23
License:        GPL-2.0+
24
Summary:        Extended Search
25
Group:          Productivity/Text/Utilities
26
Url:            http://www.lesbonscomptes.com/recoll/
27
Source:         http://www.lesbonscomptes.com/recoll/%{name}-%{version}.tar.gz
28
BuildRequires:  aspell-devel
29
%if 0%{?suse_version} > 1320
30
BuildRequires:  pkgconfig(Qt5Core)
31
BuildRequires:  pkgconfig(Qt5WebKit)
32
BuildRequires:  pkgconfig(Qt5WebKitWidgets)
33
BuildRequires:  pkgconfig(Qt5Xml)
34
BuildRequires:  pkgconfig(Qt5Network)
35
BuildRequires:  pkgconfig(Qt5PrintSupport)
36
%else
37
BuildRequires:  libQtWebKit-devel
38
BuildRequires:  libqt4-devel
39
%endif
40
BuildRequires:  bison
41
BuildRequires:  libxapian-devel
42
BuildRequires:  python-devel
43
BuildRequires:  update-desktop-files
44
# Recommends for the helpers.
45
Recommends:     antiword
46
Recommends:     poppler-tools
47
Recommends:     libwpd-tools
48
Recommends:     libxslt
49
Recommends:     catdoc
50
Recommends:     djvulibre
51
Recommends:     python-mutagen
52
Recommends:     exiftool
53
Recommends:     perl-Image-ExifTool
54
Recommends:     python-base
55
Recommends:     unrar
56
Recommends:     python-rarfile
57
Recommends:     python-PyCHM
58
Recommends:     unrtf
59
Recommends:     pstotext
60
# Default requires for recoll itself
61
Requires:       sed
62
Requires:       awk
63
Requires:       aspell
64
Requires:       python
65
Suggests:       kio_recoll
66
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
67
68
%description
69
Recoll is a personal full text search tool for Unix/Linux.
70
71
It is based on the very strong Xapian back-end, for which it provides a feature-rich yet easy to use front-end with a QT graphical interface.
72
73
Recoll is free, open source, and licensed under the GPL. The current version is 1.12.0 .
74
Features:
75
76
* Easy installation, few dependencies. No database daemon, web server, desktop environment or exotic language necessary.
77
* Will run on most unix-based systems
78
* Qt-based GUI. Can use either Qt 3 or Qt 4.
79
* Searches most common document types, emails and their attachments.
80
* Powerful query facilities, with boolean searches, phrases, proximity, wildcards, filter on file types and directory tree.
81
* Multi-language and multi-character set with Unicode based internals.
82
* (more detail)
83
84
%prep
85
%setup -q
86
87
%build
88
%if 0%{?suse_version} > 1320
89
export QMAKE=qmake-qt5
90
%endif
91
%configure --with-inotify
92
make %{?_smp_mflags}
93
94
%install
95
make DESTDIR=%{buildroot} install %{?_smp_mflags}
96
97
%post -p /sbin/ldconfig
98
99
%postun -p /sbin/ldconfig
100
101
%files
102
%defattr(-,root,root)
103
%dir %{_libdir}/recoll
104
%dir %{_datadir}/appdata
105
%{_bindir}/recoll
106
%{_bindir}/recollindex
107
%{_datadir}/recoll
108
%{_datadir}/applications/recoll-searchgui.desktop
109
%{_datadir}/appdata/recoll.appdata.xml
110
%{_datadir}/icons/hicolor
111
%{_datadir}/pixmaps/recoll.png
112
%{_libdir}/recoll/librecoll.so.%{version}
113
%{_libdir}/python2.7/site-packages/recoll
114
%{_libdir}/python2.7/site-packages/Recoll-1.0-py2.7.egg-info
115
%{_mandir}/man1/recoll.1.gz
116
%{_mandir}/man1/recollq.1.gz
117
%{_mandir}/man1/recollindex.1.gz
118
%{_mandir}/man5/recoll.conf.5.gz
119
120
%changelog
121
* Tue Apr 05 2016 Jean-Francois Dockes <jfd@recoll.org> 1.21.6-0
122
- Recoll 1.21.6, esp. for the kde5 kio
123