Switch to unified view

a b/packaging/rpm/recoll.spec
1
%define name recoll
2
%define version 1.0.16
3
%define release 1
4
5
Name:           %{name}
6
Version:        %{version}
7
Release:        %{release}
8
9
Summary:  desktop full text search tool with a qt gui
10
Source0:  http://www.recoll.org/%{name}-%{version}.tar.gz
11
URL:            http://www.recoll.org/
12
Group:          Applications/Databases
13
14
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
15
License:  GPL
16
# We build with a static link to xapian to avoid this dependency
17
#Requires:    xapian-core
18
19
%description
20
Recoll is a personal full text search package for Linux, FreeBSD and
21
other Unix systems. It is based on a very strong backend (Xapian), for
22
which it provides an easy to use, feature-rich, easy administration
23
interface.
24
25
# ---------------------------------------------------------------------------
26
27
%prep
28
%setup -q
29
30
# ---------------------------------------------------------------------------
31
32
%build
33
[ -n "$QTDIR" ] || . %{_sysconfdir}/profile.d/qt.sh
34
%configure
35
make %{?_smp_mflags} static
36
37
# ---------------------------------------------------------------------------
38
39
%install
40
rm -rf $RPM_BUILD_ROOT
41
%makeinstall
42
43
# ---------------------------------------------------------------------------
44
45
%clean
46
rm -rf $RPM_BUILD_ROOT
47
48
# ---------------------------------------------------------------------------
49
50
%files
51
%defattr(-,root,root,-)
52
%{_bindir}/*
53
%{_datadir}/%{name}
54
55
# ---------------------------------------------------------------------------
56
57
%changelog
58
* Thu Jan  5 2006 Jean-Francois Dockes <jean-francois.dockes@wanadoo.fr> 1.0.15-1
59
- Initial packaging