Switch to unified view

a/packaging/debian/rules b/packaging/debian/rules
...
...
35
    # Add here commands to configure the package.
35
    # Add here commands to configure the package.
36
    ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
36
    ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
37
37
38
38
39
#Architecture 
39
#Architecture 
40
build: build-arch build-indep
40
build: build-arch
41
41
42
build-arch: build-arch-stamp
42
build-arch: build-arch-stamp
43
build-arch-stamp:  config.status
43
build-arch-stamp:  config.status
44
  $(MAKE) static
44
  $(MAKE)
45
  touch $@
46
47
build-indep: build-indep-stamp
48
build-indep-stamp:  config.status
49
    touch $@
45
    touch $@
50
46
51
clean:
47
clean:
52
    dh_testdir
48
    dh_testdir
53
    dh_testroot
49
    dh_testroot
54
    rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
50
    rm -f build-arch-stamp #CONFIGURE-STAMP#
55
56
    # Add here commands to clean up after the build process.
51
    # Add here commands to clean up after the build process.
57
    -$(MAKE) distclean
52
    -$(MAKE) distclean
58
ifneq "$(wildcard /usr/share/misc/config.sub)" ""
59
  cp -f /usr/share/misc/config.sub config.sub
60
endif
61
ifneq "$(wildcard /usr/share/misc/config.guess)" ""
62
  cp -f /usr/share/misc/config.guess config.guess
63
endif
64
65
66
    dh_clean 
53
    dh_clean 
67
54
68
install: install-indep install-arch
55
install: install-arch
69
install-indep:
70
  dh_testdir
71
  dh_testroot
72
  dh_clean -k -i 
73
  dh_installdirs -i
74
  dh_install -i
75
56
76
install-arch:
57
install-arch:
77
    dh_testdir
58
    dh_testdir
78
    dh_testroot
59
    dh_testroot
79
    dh_clean -k -s 
60
    dh_clean -k -s 
...
...
99
    dh_installdeb
80
    dh_installdeb
100
    dh_shlibdeps
81
    dh_shlibdeps
101
    dh_gencontrol
82
    dh_gencontrol
102
    dh_md5sums
83
    dh_md5sums
103
    dh_builddeb
84
    dh_builddeb
104
# Build architecture independant packages using the common target.
105
binary-indep: build-indep install-indep
106
  $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
107
85
108
# Build architecture dependant packages using the common target.
86
# Build architecture dependant packages using the common target.
109
binary-arch: build-arch install-arch
87
binary-arch: build-arch install-arch
110
    $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
88
    $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
111
89
112
binary: binary-arch binary-indep
90
binary: binary-arch 
113
.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch 
91
.PHONY: build clean binary-arch binary install install-arch