Switch to unified view

a/debian/rules b/debian/rules
...
...
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
export DEB_BUILD_HARDENING=1
11
export DEB_BUILD_HARDENING=1
12
12
13
build: build-stamp
13
# OPENHOME=/opt/openhome
14
OPENHOME=openhome
14
15
15
build-stamp:
16
%:
16
  dh build --before configure
17
  dh $@
17
  dh_auto_configure -- --with-openhome=/opt/openhome
18
  dh build --after configure
19
  touch build-stamp
20
18
21
clean:
19
override_dh_auto_configure:
22
  dh clean
20
  test ! -d $(OPENHOME) && sh ./ohbuild.sh $(OPENHOME)
23
21
  dh_auto_configure -- --with-openhome=$(OPENHOME)
24
install: build install-stamp
25
install-stamp:
26
  dh install
27
  touch install-stamp
28
29
binary-arch: install
30
  dh binary-arch
31
32
binary-indep: install
33
  dh binary-indep
34
35
binary: binary-arch binary-indep