Switch to unified view

a b/archlinux/PKGBUILD
1
# Contributor: Markus M. May <triplem@javafreedom.org>
2
3
pkgname=upmpdcli
4
pkgver=0.5
5
pkgrel=1
6
pkgdesc="an UPnP front-end to the Music Player Daemon"
7
license="GPL"
8
builddepends=(autoconf)
9
arch=(i686 x86_64)
10
11
source=("https://github.com/medoc92/upmpdcli/archive/v0.5.tar.gz")
12
md5sums=('0e6623503f18eb7230aef8334084af4e')
13
14
backup=()
15
url="http://www.lesbonscomptes.com/upmpdcli/"
16
17
18
build() {
19
20
  cd ${srcdir}/${pkgname}-${pkgver}
21
22
  # this is temporary - should be fixed in the git repo
23
  chmod u+x autogen.sh
24
25
  msg "Run autogen.sh"
26
  ./autogen.sh
27
28
  msg "Run configure"
29
  ./configure --prefix=/usr
30
31
  msg "Run make"
32
  make
33
}
34
35
package() {
36
37
  msg "Make install"
38
  cd ${srcdir}/${pkgname}-${pkgver}
39
40
  msg "pkgdir: ${pkgdir}"
41
  make DESTDIR="${pkgdir}/" install
42
43
}
44
# :mode=shellscript: