a/packaging/rpm/recoll.spec b/packaging/rpm/recoll.spec
1
# Turn off the brp-python-bytecompile script
2
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
3
1
Summary:        Desktop full text search tool with Qt GUI
4
Summary:        Desktop full text search tool with Qt GUI
2
Name:           recoll
5
Name:           recoll
3
Version:        1.23.3
6
Version:        1.23.7
4
Release:        1%{?dist}
7
Release:        2%{?dist}
5
Group:          Applications/Databases
8
Group:          Applications/Databases
6
License:        GPLv2+
9
License:        GPLv2+
7
URL:            http://www.lesbonscomptes.com/recoll/
10
URL:            http://www.lesbonscomptes.com/recoll/
8
Source0:        http://www.lesbonscomptes.com/recoll/recoll-%{version}.tar.gz
11
Source0:        http://www.lesbonscomptes.com/recoll/recoll-%{version}.tar.gz
12
Source10:       qmake-qt5.sh
13
Patch0:         recoll-simpleregexp-vector-provision.patch
9
BuildRequires:  aspell-devel
14
BuildRequires:  aspell-devel
10
BuildRequires:  bison
15
BuildRequires:  bison
11
BuildRequires:  desktop-file-utils
16
BuildRequires:  desktop-file-utils
12
# kio
17
# kio
13
BuildRequires:  kdelibs4-devel
18
BuildRequires:  kdelibs4-devel
14
BuildRequires:  qt5-qtbase-devel
19
BuildRequires:  qt5-qtbase-devel
15
BuildRequires:  qt5-qtwebkit-devel
20
BuildRequires:  qt5-qtwebkit-devel
16
BuildRequires:  extra-cmake-modules
21
BuildRequires:  extra-cmake-modules
17
BuildRequires:  kf5-kio-devel
22
BuildRequires:  kf5-kio-devel
18
BuildRequires:  python2-devel
23
BuildRequires:  python2-devel
24
BuildRequires:  python3-devel
19
BuildRequires:  xapian-core-devel
25
BuildRequires:  xapian-core-devel
20
BuildRequires:  zlib-devel
26
BuildRequires:  zlib-devel
21
Requires:       xdg-utils
27
Requires:       xdg-utils
22
28
23
%description
29
%description
...
...
36
appropriate URL in a KDE open dialog, or with an HTML-based interface
42
appropriate URL in a KDE open dialog, or with an HTML-based interface
37
displayed in Konqueror.
43
displayed in Konqueror.
38
44
39
%prep
45
%prep
40
%setup -q -n %{name}-%{version}
46
%setup -q -n %{name}-%{version}
47
%patch0 -p2
41
48
42
%build
49
%build
43
CFLAGS="%{optflags}"; export CFLAGS
50
CFLAGS="%{optflags}"; export CFLAGS
44
CXXFLAGS="%{optflags}"; export CXXFLAGS
51
CXXFLAGS="%{optflags}"; export CXXFLAGS
45
LDFLAGS="%{?__global_ldflags}"; export LDFLAGS
52
LDFLAGS="%{?__global_ldflags}"; export LDFLAGS
46
53
47
# force use of custom/local qmake, to inject proper build flags (above)
54
# force use of custom/local qmake, to inject proper build flags (above)
55
install -m755 -D %{SOURCE10} qmake-qt5.sh
48
export QMAKE=qmake-qt5
56
export QMAKE=qmake-qt5
49
57
50
%configure
58
%configure
51
make %{?_smp_mflags}
59
make %{?_smp_mflags}
52
60
...
...
79
popd
87
popd
80
)
88
)
81
89
82
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
90
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
83
echo "%{_libdir}/recoll" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-%{_arch}.conf
91
echo "%{_libdir}/recoll" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-%{_arch}.conf
92
93
# Mix of Python 2 and 3, needs special care
94
95
py2_byte_compile () {
96
    bytecode_compilation_path="$1"
97
    find $bytecode_compilation_path -type f -a -name "*.py" -print0 | xargs -0 %{__python2} -O -c 'import py_compile, sys; [ py_compile.compile(f, dfile=f.partition("%{buildroot}")[2]) for f in sys.argv[1:] ]' || :
98
    find $bytecode_compilation_path -type f -a -name "*.py" -print0 | xargs -0 %{__python2} -c 'import py_compile, sys; [ py_compile.compile(f, dfile=f.partition("%{buildroot}")[2]) for f in sys.argv[1:] ]' || :
99
}
100
101
py3_byte_compile () {
102
    bytecode_compilation_path="$1"
103
    find $bytecode_compilation_path -type f -a -name "*.py" -print0 | xargs -0 %{__python3} -O -c 'import py_compile, sys; [py_compile.compile(f, dfile=f.partition("%{buildroot}")[2], optimize=opt) for opt in range(2) for f in sys.argv[1:] ]' || :
104
}
105
106
py2_byte_compile %{buildroot}%{python2_sitearch}/recoll
107
108
for py in %{buildroot}%{_datadir}/%{name}/filters/*.py; do
109
    if [ "$(basename $py)" = "recoll-we-move-files.py" ]; then
110
  py3_byte_compile $py
111
    else
112
  py2_byte_compile $py
113
    fi
114
done
84
115
85
%post
116
%post
86
touch --no-create %{_datadir}/icons/hicolor
117
touch --no-create %{_datadir}/icons/hicolor
87
if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
118
if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
88
  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
119
  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
...
...
134
%{_datadir}/kio_recoll/welcome.html
165
%{_datadir}/kio_recoll/welcome.html
135
%{_datadir}/kservices5/recoll.protocol
166
%{_datadir}/kservices5/recoll.protocol
136
%{_datadir}/kservices5/recollf.protocol
167
%{_datadir}/kservices5/recollf.protocol
137
168
138
%changelog
169
%changelog
139
* Mon Sep 04 2017 J.F. Dockes <jfd@recoll.org> - 1.23.3-1
170
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.23.7-2
140
 1.23.3: misc small fixes
171
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
141
172
173
* Tue Jan 09 2018 Terje Rosten <terje.rosten@ntnu.no> - 1.23.7-1
174
- 1.23.7
175
176
* Sat Dec 09 2017 Terje Rosten <terje.rosten@ntnu.no> - 1.23.6-1
177
- 1.23.6
178
179
* Mon Sep 04 2017 Terje Rosten <terje.rosten@ntnu.no> - 1.23.3-1
180
- 1.23.3
181
182
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.23.2-3
183
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
184
185
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.23.2-2
186
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
187
188
* Mon May 15 2017 Terje Rosten <terje.rosten@ntnu.no> - 1.23.2-1
189
- 1.23.2
190
191
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23.1-2
192
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
193
142
* Sat Mar 11 2017 Terje Rosten <terje.rosten@ntnu.no> - 1.23.0-1
194
* Mon Mar 13 2017 Terje Rosten <terje.rosten@ntnu.no> - 1.23.1-1
143
- 1.23.0
195
- 1.23.1
144
196
145
* Sat Feb 18 2017 Terje Rosten <terje.rosten@ntnu.no> - 1.22.4-1
197
* Sat Feb 18 2017 Terje Rosten <terje.rosten@ntnu.no> - 1.22.4-1
146
- 1.22.4
198
- 1.22.4
147
199
148
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.3-3
200
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.3-3