a b/archlinux/PKGBUILD
1
# Contributor: Markus M. May <triplem@javafreedom.org>
2
3
pkgname=upmpdcli
4
pkgver=0.5
5
pkgrel=1
6
pkgdesc="an UPnP front-end to the Music Player Daemon"
7
license="GPL"
8
depends=('libupnp')
9
builddepends=(autoconf)
10
arch=(i686 x86_64)
11
12
source=("http://github.com/medoc92/upmpdcli/archive/v0.5.tar.gz")
13
md5sums=('0e6623503f18eb7230aef8334084af4e')
14
15
backup=()
16
url="http://www.lesbonscomptes.com/upmpdcli/"
17
18
19
build() {
20
21
  cd ${srcdir}/${pkgname}-${pkgver}
22
23
  # this is temporary - should be fixed in the git repo
24
  chmod u+x autogen.sh
25
26
  msg "Run autogen.sh"
27
  ./autogen.sh
28
29
  msg "Run configure"
30
  ./configure --prefix=/usr
31
32
  msg "Run make"
33
  make
34
}
35
36
package() {
37
38
  msg "Make install"
39
  cd ${srcdir}/${pkgname}-${pkgver}
40
41
  msg "pkgdir: ${pkgdir}"
42
  make DESTDIR="${pkgdir}/" install
43
44
}
45
# :mode=shellscript: