--- a/packaging/debian/rules
+++ b/packaging/debian/rules
@@ -1,14 +1,4 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-#
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-# Modified to make a template file for a multi-binary package with separated
-# build-arch and build-indep targets by Bill Allombert 2001
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -21,7 +11,6 @@
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -32,50 +21,41 @@
config.status: configure
dh_testdir
- # Add here commands to configure the package.
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
+ ./configure CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs" \
+ --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
+ --prefix=/usr --mandir=\$${prefix}/share/man
-
-#Architecture
-build: build-arch
-
-build-arch: build-arch-stamp
-build-arch-stamp: config.status
+build: build-stamp
+build-stamp: config.status
+ dh_testdir
$(MAKE)
touch $@
clean:
dh_testdir
dh_testroot
- rm -f build-arch-stamp #CONFIGURE-STAMP#
- # Add here commands to clean up after the build process.
+ rm -f build-stamp
-$(MAKE) distclean
dh_clean
-install: install-arch
-
-install-arch:
+install:
dh_testdir
dh_testroot
- dh_clean -k -s
- dh_installdirs -s
- $(MAKE) install prefix=$(CURDIR)/debian/recoll/usr
+ dh_clean -k
+ dh_installdirs
- dh_install -s
-# Must not depend on anything. This is to be called by
-# binary-arch/binary-indep
-# in another 'make' thread.
-binary-common:
+ $(MAKE) prefix=$(CURDIR)/debian/recoll/usr install
+
+binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs ChangeLog
dh_installdocs
- dh_installexamples
dh_installmenu
dh_installman
dh_link
dh_strip
- dh_compress
+ dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
@@ -83,9 +63,7 @@
dh_md5sums
dh_builddeb
-# Build architecture dependant packages using the common target.
-binary-arch: build-arch install-arch
- $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
+binary-indep: build install
-binary: binary-arch
-.PHONY: build clean binary-arch binary install install-arch
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install