Parent: [52026f] (diff)

Child: [e2d977] (diff)

Download this file

rules    40 lines (32 with data), 1.4 kB

#!/usr/bin/make -f
# See debhelper(7) (uncomment to enable)
# output every command that modifies files on the build system.
#DH_VERBOSE = 1

# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk

# see FEATURE AREAS in dpkg-buildflags(1)
#export DEB_BUILD_MAINT_OPTIONS = hardening=+all

# see ENVIRONMENT in dpkg-buildflags(1)
# package maintainers to append CFLAGS
#export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
# package maintainers to append LDFLAGS
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed

# main packaging script based on dh7 syntax
%:
	dh $@ --parallel --with python2 --with python3 --with autotools-dev 

override_dh_auto_configure:
	dh_auto_configure -- --enable-recollq --enable-xadump

build3vers := $(shell py3versions -sv)

override_dh_auto_install:
	dh_auto_install
	(cd python/recoll; python setup.py install \
	                                   --install-layout=deb \
	                                   --prefix=$(CURDIR)/debian/tmp/usr )
	set -e && for i in $(build3vers); do \
	(cd python/recoll; libdir=/usr/lib/$${DEB_BUILD_MULTIARCH} python$$i \
					./setup.py install \
	                                --install-layout=deb \
	                                --prefix=$(CURDIR)/debian/tmp/usr ) ; \
	done
	find $(CURDIR) -type f -name '*.la' -exec rm -f '{}' \;