Parent: [c1d355] (diff)

Child: [52026f] (diff)

Download this file

rules    97 lines (82 with data), 2.5 kB

#!/usr/bin/make -f

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

export DEB_BUILD_MAINT_OPTIONS = hardening=+all

DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)

CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS) $(CPPFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)

build3vers := $(shell py3versions -sv)

#build qt5 UI
export QT_SELECT := qt5

ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
	CFLAGS += -O0
else
	CFLAGS += -O2
endif

config.status: configure
	dh_testdir
	./configure CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
		    --host=$(DEB_HOST_GNU_TYPE) \
		    --build=$(DEB_BUILD_GNU_TYPE) \
		    --mandir=\$${prefix}/share/man \
		    --prefix=/usr \
		    --enable-recollq \
		    --enable-xadump

build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp: config.status
	dh_testdir
	$(MAKE)
	touch $@

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp config.log
	[ ! -f Makefile ] || $(MAKE) distclean
	dh_clean Makefile

install:
	dh_testdir
	dh_testroot
	dh_prep
	dh_installdirs
	$(MAKE) STRIP=ls prefix=$(CURDIR)/debian/tmp/usr install
	# Executable fixes
	chmod +x $(CURDIR)/debian/tmp/usr/share/recoll/examples/rclmon.sh
	chmod -x $(CURDIR)/debian/tmp/usr/share/recoll/filters/rclexec1.py
	chmod -x $(CURDIR)/debian/tmp/usr/share/recoll/filters/rclxslt.py
	find $(CURDIR) -type f -name '*.la' -exec rm -f '{}' \;
	(cd python/recoll; python setup.py install \
	                                   --install-layout=deb \
	                                   --prefix=$(CURDIR)/debian/tmp/usr )
	set -e && for i in $(build3vers); do \
	  (cd python/recoll; python$$i ./setup.py install \
	                                   --install-layout=deb \
	                                   --prefix=$(CURDIR)/debian/tmp/usr ) ; \
	done

binary-arch: build install
	dh_testdir
	dh_testroot
	dh_installchangelogs ChangeLog
	dh_installdocs README
	dh_installman
	dh_install --sourcedir=debian/tmp
	dh_makeshlibs
	dh_python2 -p python-recoll
	dh_python3 -p python3-recoll
	dh_link
	dh_strip --no-automatic-dbgsym
	dh_compress
	dh_fixperms
	dh_lintian
	dh_installdeb
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary-indep: build install

binary: binary-indep binary-arch
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install