Parent:
[ce6914]
(diff)
Download this file
rules
24 lines (19 with data), 740 Bytes
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
export DEB_BUILD_HARDENING=1
# OPENHOME=/opt/openhome
OPENHOME=openhome
%:
dh $@
# Note: this supposes that the openhome tarfile has been extracted in
# the source tree prior to launching the build.
override_dh_auto_configure:
sh ./ohbuild.sh $(OPENHOME)
dh_auto_configure -- --with-openhome=$(OPENHOME)