Parent: [02c38c] (diff)

Child: [7119d0] (diff)

Download this file

rules    87 lines (74 with data), 2.2 kB

#!/usr/bin/make -f

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk

DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)

CFLAGS += -Wall -g
#LDFLAGS += -Wl,-z,defs

ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
	CFLAGS += -O0
else
	CFLAGS += -O2
endif

config.status: configure
	dh_testdir
	./configure CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
		    --host=$(DEB_HOST_GNU_TYPE) \
		    --build=$(DEB_BUILD_GNU_TYPE) \
		    --mandir=\$${prefix}/share/man \
		    --prefix=/usr

build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp: config.status
	dh_testdir
	$(MAKE) -j 5
	touch $@

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp config.log
	[ ! -f Makefile ] || $(MAKE) distclean
	dh_clean Makefile

install:
	dh_testdir
	dh_testroot
	dh_prep
	dh_installdirs
	$(MAKE) prefix=$(CURDIR)/debian/tmp/usr install
	chmod a+x $(CURDIR)/debian/tmp/usr/share/recoll/examples/rclmon.sh
	chmod a-x $(CURDIR)/debian/tmp/usr/share/recoll/filters/rclxslt.py
	chmod a-x $(CURDIR)/debian/tmp/usr/share/recoll/filters/rclexec1.py
	chmod a-x $(CURDIR)/debian/tmp/usr/share/recoll/filters/rclexec1.py
	rm -f $(CURDIR)/debian/tmp/usr/lib/recoll/librecoll.la
	(cd python/recoll; python setup.py install \
	                                   --install-layout=deb \
	                                   --prefix=$(CURDIR)/debian/tmp/usr )
	(cd python/recoll; python3 setup.py install \
	                                   --install-layout=deb \
	                                   --prefix=$(CURDIR)/debian/tmp/usr )

binary-arch: build install
	dh_testdir
	dh_testroot
	dh_installchangelogs ChangeLog
	dh_installdocs README
	dh_installmenu
	dh_installman
	dh_install --sourcedir=debian/tmp
	dh_makeshlibs
	dh_python2 -p python-recoll
	dh_python3 -p python3-recoll
	dh_link
	dh_strip
	dh_compress
	dh_fixperms
	dh_installdeb
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary-indep: build install

binary: binary-indep binary-arch
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install