Switch to unified view

a/packaging/debian/debian/rules b/packaging/debian/debian/rules
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
2
3
# Uncomment this to turn on verbose mode.
3
# Uncomment this to turn on verbose mode.
4
#export DH_VERBOSE=1
4
#export DH_VERBOSE=1
5
5
6
export DEB_BUILD_HARDENING=1
6
DPKG_EXPORT_BUILDFLAGS = 1
7
include /usr/share/dpkg/buildflags.mk
7
8
8
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
9
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
9
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
10
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
10
11
11
CFLAGS = -Wall -g
12
CFLAGS += -Wall -g
12
#LDFLAGS = -Wl,-z,defs
13
#LDFLAGS += -Wl,-z,defs
13
14
#build qt4 UI only
15
#export QMAKE=qmake-qt4
16
14
17
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18
    CFLAGS += -O0
16
    CFLAGS += -O0
19
else
17
else
20
    CFLAGS += -O2
18
    CFLAGS += -O2
...
...
31
build: build-arch build-indep
29
build: build-arch build-indep
32
build-arch: build-stamp
30
build-arch: build-stamp
33
build-indep: build-stamp
31
build-indep: build-stamp
34
build-stamp: config.status
32
build-stamp: config.status
35
    dh_testdir
33
    dh_testdir
36
    $(MAKE)
34
    $(MAKE) -j 5
37
    touch $@
35
    touch $@
38
36
39
clean:
37
clean:
40
    dh_testdir
38
    dh_testdir
41
    dh_testroot
39
    dh_testroot
...
...
46
install:
44
install:
47
    dh_testdir
45
    dh_testdir
48
    dh_testroot
46
    dh_testroot
49
    dh_prep
47
    dh_prep
50
    dh_installdirs
48
    dh_installdirs
51
    $(MAKE) STRIP=ls prefix=$(CURDIR)/debian/tmp/usr install
49
    $(MAKE) prefix=$(CURDIR)/debian/tmp/usr install
52
  # Work around recollinstall forgetting the PPT text-extract utility
50
  chmod a+x $(CURDIR)/debian/tmp/usr/share/recoll/examples/rclmon.sh
53
  install -m 0444 filters/msodump.zip $(CURDIR)/debian/tmp/usr/share/recoll/filters
51
  chmod a-x $(CURDIR)/debian/tmp/usr/share/recoll/filters/rclxslt.py
54
  install -m 0555 filters/ppt-dump.py $(CURDIR)/debian/tmp/usr/share/recoll/filters
52
  chmod a-x $(CURDIR)/debian/tmp/usr/share/recoll/filters/rclexec1.py
53
  chmod a-x $(CURDIR)/debian/tmp/usr/share/recoll/filters/rclexec1.py
54
  rm -f $(CURDIR)/debian/tmp/usr/lib/recoll/librecoll.la
55
    (cd python/recoll; python setup.py install \
55
    (cd python/recoll; python setup.py install \
56
                                       --install-layout=deb \
56
                                       --install-layout=deb \
57
                                       --prefix=$(CURDIR)/debian/tmp/usr )
57
                                       --prefix=$(CURDIR)/debian/tmp/usr )
58
    (cd python/recoll; python3 setup.py install \
58
    (cd python/recoll; python3 setup.py install \
59
                                       --install-layout=deb \
59
                                       --install-layout=deb \